Emby synchroniseert bibliotheek niet meer

Ik gebruik Emby als media-server. In een niet zo ver verleden draaide Emby op de server waar ook de mediabestanden zich bevonden, maar om mijn thuisinfrastructuur een beetje op orde te zetten werd de mediaserver verplaatst naar een nieuw systeem, met een CPU die in staat (zou moeten zijn) is om snel en goed te converteren.

De films en video’s bleven op de NAS, dus werd die laatste een beetje aangepast om niet alleen SAMBA, maar ook NFS beschikbaar te maken. Alles stond goed, het doelsysteem zag de bestanden en Emby werd opgestart. Het was niet allemaal rozengeur en maneschijn, want het toevoegen van nieuwe films bleek niet te werken. Emby herstarten, het systeem herstarten, de bibliotheek verwijderen en opnieuw toevoegen; geen oplossing.

Een ding had ik over het hoofd gezien: gebruikers. De rechten op de NFS-share stonden in principe goed ingesteld (664 of 775), maar de eigenaars waren niet gelijk tussen doel en bron. Om één of andere reden bracht dat Emby in de war.

Gelukkig is dat niet moeilijk om op te lossen:

  1. Zoek uit als welke gebruiker Emby draait (doel). Omdat het niet de naam, maar de UID is die gedeeld wordt, heb je de UID en GID van die gebruiker nodig. In mijn geval 999 en 999.
  2. Wanneer die ID’s al in gebruik zijn op het bronsysteem, probeer dan om op het doelsysteem de UID en GID te veranderen. Dit is niet zo eenvoudig; eventueel kan je Emby ook als een andere gebruiker draaien.
  3. Maak op het bronsysteem een gebruiker aan met dezelfde UID en GID.

useradd -d /var/lib/emby -m -u 999 -s /usr/bin/nologin emby

In principe wordt de groep hiermee ook aangemaakt. Mocht dat niet zo zijn.

groupadd -g 999 emby

Herstart Emby en voer een nieuwe scan uit van de bibliothe(e)k(en); en voila,, de nieuwe films komen tevoorschijn!